c语言使用指针将字符串s1中的子串s2删除,并返回字符串s1中剩余字符串个数及其长度?
发布网友
发布时间:2022-04-09 07:24
我来回答
共1个回答
热心网友
时间:2022-04-09 08:53
输入样例:
Thisisatest is
输出样例:
Thatest
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int main()
{
//char s[]="hello world";
//printf("%s\n",s);
char s1[80]={0,};
char s2[80]={0,};
int i,num;
scanf("%s",s1);
scanf("%s",s2);
//char *p=strstr(s1,s2);
while (strstr(s1,s2)){
i=0;
num=strlen(s1);
char *p=strstr(s1,s2); //返回在s1中找到的第一个s2字符串地址
int cnt=strlen(p); //cnt等于所找到的当前s2字符串地址之后所有的字符串个数
while (i!=strlen(s2)){
*p++='\0'; //对p中的s2字符串置'\0',并将p移至下一个地址
i++;
}
strcpy(s1+(num-cnt),p); //往前移位,即num-cnt为当前s1字符串的字符个数
}
num=strlen(s1);
//printf("%s\n",p);
for (i=0;i<=num;i++){
printf("%c",s1[i]);
}
return 0;
}